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如何解决MSE Nacos开源控制台无法使用问题

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本文介绍如何解决MSE Nacos开源控制台无法使用问题。

问题现象

  • 开源控制台上提示caused: No AuthenticationProvider found for org.springframework.security.authentication.UsernamePasswordAuthenticationToken;

  • 开源控制台上单击登录,提示用户名密码错误

  • 开源控制台上提示authorization failed:access ak system failed.

  • 开源控制台上提示没有命名空间的访问权限!

可能原因

MSE Nacos在开启鉴权功能时,使用的是阿里云RAM控制台,不支持开源的默认鉴权插件。在开启RAM鉴权后,开源控制台也因为缺少RAM用户信息,导致控制台无法使用。关于MSE Nacos鉴权功能的详细信息,请参见Nacos Client访问鉴权

说明

不建议使用开源控制台,请使用MSE控制台, MSE控制台功能丰富且更安全。

解决方案

  1. 确认是否已经打开鉴权功能。具体操作,请参见Nacos Client访问鉴权

    • 若已开启鉴权功能,请使用MSE控制台对Nacos进行操作。

    • 若未开启鉴权功能,请确认登录框中输入的用户名密码是否正确,可以检测大小写开关或关闭输入法后重试。

    说明

    MSE Nacos未开启鉴权时的登录页为社区版本自带功能,仅区别不同使用者,实际没有鉴权能力。建议开启鉴权功能并使用MSE控制台进行更安全的操作。

  2. 进行RAM用户的创建及授权,对RAM用户进行不同粒度的赋权。具体操作,请参见注册配置中心授权

  3. 在客户端配置对应的身份信息(例如AccessKey或RoleName等)。具体操作,请参见Nacos Client访问鉴权

  4. 移除应用程序中关于开源鉴权插件的usernamepassword相关配置,避免频繁打印login failed错误。

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